This project is read-only.

Can't find MSMQ.dll

Sep 13, 2011 at 3:44 AM

Hi, I've decided to try Simple Service Bus, but when I tried to compile it, I couldn't find a reference for MSMQ.dll.

I installed MSMQ on Windows 7, and I'm using Visual Studio 2010 Professional.

Does anyone know where this assembly is located?

Sep 13, 2011 at 3:56 AM

You have to go into Win7's control panel, then go to programs and start "Turn Windows features on and off".

Enable MSMQ there and you should be ok.

Sep 13, 2011 at 6:17 AM

Yes, I did that, but that only enables MSMQ, I'm looking for the DLL referenced in the solution(MSMQ.dll) so I can compile it.

Sep 13, 2011 at 8:47 AM

Ok, I solved the problem by getting Interop.MSMQ.dll from NServiceBus to resolve the dependency.

This DLL should probably be included in the lib section, because once I placed it there, the dependency resolver automagically!

Sep 13, 2011 at 6:17 PM

I couldn't find it on my Win7 machine either (but the COM class exists in registry, it just doesn't show up in the Add Reference list). I added the interop file to lib, thanks for bringing this to our attention.

Sep 14, 2011 at 5:40 AM

No Problem!

Dec 19, 2011 at 8:31 PM

I was able to resolve it but switching all project to .net 4.0 after installing msmq (in visual studio 2010)

Dec 23, 2011 at 5:36 PM

Good! Thanks for following up!